Advanced Data Analysis: From Excel PivotTables to Microsoft Access

Christopher C. Brown
University of Denver, christopher.brown@du.edu

Denise Pan
University of Colorado Denver, dpan@uw.edu

Gabrielle Wiersma
University of Colorado at Boulder, gabrielle.wiersma@colorado.edu

Follow this and additional works at: http://docs.lib.purdue.edu/charleston

Part of the Library and Information Science Commons
An indexed, print copy of the Proceedings is also available for purchase at: http://www.thepress.purdue.edu/series/charleston.
You may also be interested in the new series, Charleston Insights in Library, Archival, and Information Sciences. Find out more at: http://www.thepress.purdue.edu/series/charleston-insights-library-archival-and-information-sciences.

http://dx.doi.org/10.5703/1288284315592

This document has been made available through Purdue e-Pubs, a service of the Purdue University Libraries. Please contact epubs@purdue.edu for additional information.
Advanced Data Analysis: From Excel PivotTables to Microsoft Access

Christopher C. Brown, University of Denver
Denise Pan, University of Colorado Denver
Gabrielle Wiersma, University of Colorado at Boulder

Abstract

Most librarians run for the hills when they hear about Microsoft Excel PivotTables and relational databases such as Microsoft Access. PivotTables can be a powerful analysis tool. However, Microsoft Access can move beyond PivotTables by exploring more complex relationships between datasets. Building from the morning session, participants learned additional Excel functions including PivotTables and PivotCharts, as well as Access tables, queries, forms, and reports. The session was held in a classroom with computers, so attendees received sample data to create PivotTables, PivotCharts, and their own relational database during this hands-on workshop. Readers of this proceeding may request sample data for the Excel PivotTable presentation by email correspondence with the lead author (denise.pan@ucdenver.edu).

Introduction

In 2013, librarians from the University of Colorado (CU) Boulder and Denver campuses collaborated to offer an Excel workshop at the 2013 Charleston Conference. They frequently used Excel in their work and would share what they learned with one another. In turn, the librarians thought that others would also find these tips and tricks useful. By no means do they claim to know everything about Excel. Rather, they are sharing what they have learned from self-taught trial and error. While the 2013 session was well-attended and received, the speakers tried to cover too much information in one session. As a result, for the 2014 Preconference, they created another session for PivotTables and invited a University of Denver librarian to introduce Microsoft Access. Including Access seemed to be a natural next step in their data analysis workshop because at a certain point the data becomes too cumbersome to analyze in an Excel worksheet, and a relational database is needed. Specifically, this proceeding gives an introduction to Excel PivotTable features and functions.

Excel Worksheet Data for PivotTables and Pivot Charts

To make the workshop relevant to acquisitions and collection development librarians, the participants evaluated data for a fictitious journal cancellation project using information available in an Excel worksheet. It is assumed that that the data has been prepared in advance by exporting a journal title list and cost data from an Integrated Library Management System, and several years of usage data has been added into the worksheet. By including relevant data in a worksheet, it can be summarized, analyzed, and visualized with PivotTables and PivotCharts. For information on how to import data using VLookup, see the 2013 and 2014 Excelling with Excel Proceedings. The screenshot below shows the first 15 rows of data provided to session participants. Please note, instructions are provided for Microsoft Excel 2013.
When making an Excel worksheet and before creating PivotTables, make sure that there are no blank or unlabeled columns in the worksheet. Excel will not be able to generate a PivotTable. Without a header the field is undefined. Other best practices including the following:

- Use short and unique phrases in headers.
- Avoid using special characters because some characters will cause Excel to ignore that particular column.
- If you sum totals in the bottom row of a table, avoid including the total row in your source data. Otherwise, the total row will be included in your PivotTable as if it is another row of data or journal title.
- Excel can only pivot or analyze the rows or values that already exist in your worksheet. Therefore, derived valued (e.g., Cost per Use and Total Use) must be calculated in advance of inserting a PivotTable.

Creating PivotTables

Create a PivotTable from an existing Excel worksheet.

Instructions

1. Select ALL contents of the worksheet (Ctrl+A or click triangle in corner of A1). Or select a specific range of data ($A$1:$L$100).
2. Click on the PivotTable button in the Insert tab.
3. This will open the Create PivotTable window. Click OK to create new worksheet (default).

Figure 1. Excel worksheet data.

Figure 2. Create PivotTable.
Summary by Subject

This first example demonstrates how to answer the question “What is the count and cost of journals by subject?” with a PivotTable. It is possible to use Excel filters to sort and display a particular subject area. However, PivotTables will summarize the data in one table. Specifically, this scenario highlights the following aspects of PivotTables:

- Subtotal and summarize data by categories and subcategories.
- Expand and collapse levels of data to focus your results.
- Drill down to details from the summary data.
- Summarize data with a calculation type (e.g. sum, count, average, max, min, and product).

Instructions

1. Create new PivotTable worksheet (see Creating PivotTables section).
2. Rename worksheet as “by subject.”
3. Drag and drop fields into the report.
   a. Rows: Subject and Journal Titles.
   b. Values: Journal Title and 2013 Sub Cost (Note: Report Filter will be blank and Columns will default to Values).
4. For 2013 Sub Cost in Values, click down arrow and select Value Field Settings.
5. Change Value Field Settings to Sum for Subscription Cost. Then click Number Format button to display the data in Accounting format ($X.XX). Click OK, OK.

Figure 3. Summary by subject fields and values.
Analysis by Fund Code or Subject Librarian

The next example answers the question, “What is the total and average cost by fund or librarian?” It is also an opportunity to demonstrate how to pivot rows and also use the “average” calculation type.

Instructions

1. Create new PivotTable worksheet.
2. Rename worksheet as “by Fund.”
3. Drag and drop fields into the report.
   a. Rows: Fund and Librarian.
   b. Values: Journal Title, 2013 Sub Cost twice.
4. Change Value Field Settings for first Subscription Cost to sum change the number format to Accounting.
5. For second Subscription Cost to average change the number format to Accounting.
6. Make a copy of “by Fund” worksheet and rename as “by Librarian.”
7. Move Librarian up and Fund down.

Top 10 and Zero Use Titles

In the next example we will use filters to show the journal titles with the Top 10 highest used titles and all of the Zero use titles. The PivotTable can be used to answer the question—Which journal titles are used most/least?

Instructions

1. Create new PivotTable worksheet Rename worksheet as “Top 10.”
2. Drag and drop fields into the report.
   a. Row Labels: Journal Titles.
   b. Values: 2013 Cost per use, and Total Usage.
3. Change Value Field Settings for Subscription Cost to sum and change the number format to Accounting; and 2012 Usage to sum.
4. Select the filter icon in Row Labels, select Value Filters, and Top 10.

5. In the Top 10 Filter (Journal Title) window change the drop down to Sum of Total Usage.

6. Make a copy of “Top 10” and rename as “Zero Use.”

7. Select the filter icon in Row Labels, select Value Filters, and Equals.

8. In the Value Filter (Journal Title) window change drop downs to display Sum of Total Usage equals 0.

Chart Usage by Subject
Charts provide a visual representation of your data. They show big picture trends and relationships between different series of data in a graphical format. Similarly, PivotChart can help you see comparisons and patterns from PivotTable report summary data. For our example we will create a PivotChart to look at the usage over time by subject area.

Instructions
1. Create PivotChart worksheet by selecting “PivotChart” from the Insert tab.
2. Rename worksheet “Historical Usage.”
3. Drag and drop fields into the report.
   a. Axis (Categories): Subject.
4. Change Value Field Settings for all of the usage values to sum.
5. Excel will build the PivotTable and PivotChart, while you are changing the PivotTable Field List.
6. Customize the look and feel of the PivotChart from the PivotChart Tools > Design Tab > Change Chart Type (e.g., Stacked Line).

Figure 6: Create PivotChart.

Figure 7. Change Chart Type.
PivotTable to PivotChart

Excel automatically creates a PivotChart when you are building a PivotTable.

Instructions

1. Make a copy of a worksheet that already has a PivotTable (e.g., Zero Use).
2. Rename the worksheet as “Chart Zero Use.”
3. Click in the PivotTable to display the Analyze tab (Options tab in Excel 2010) PivotTable Tools, and then click the PivotChart Button.

4. The Insert Chart window will display. Select the type of chart you want to use (e.g., Column). OK.
5. Excel will create the PivotChart. Use Design tab in PivotChart Tools to customize the chart.

Conclusion

PivotTables and PivotCharts allow librarians to summarize, analyze, explore, visualize, and present data from their Excel worksheets. They are able to see comparisons, patterns, and trends. As a result, they have knowledge to make informed decisions about collection data. This session highlighted the following Excel features:

- Subtotal and summarize data by categories and subcategories.
- Expand/collapse levels of data.
- Summarize data with a calculation type (sum, count, average, max, min, product).
- Flip or pivot data.
- Filtering to limit results (Top 10 and zero use).
- Creating Pivot Charts.

In turn, these functions enabled participants to answer the following questions about their sample journal and cost data:

- What is the count and cost of journal by subject?
- What is the total and average cost by fund or librarian?
- Which titles are used most or least?
- What is the usage over time by subject area?

This presentation and paper demonstrated the power and possibilities of using PivotTables and PivotCharts in Acquisitions and Collection Development assessment activities.
Part 2. Microsoft Access

Christopher C. Brown

Most librarians run for the hills when they hear about Microsoft Excel PivotTables and relational databases such as Microsoft Access. PivotTables can be a powerful analysis tool. However, Microsoft Access can move beyond PivotTables by exploring more complex relationships between datasets. This session begins with an overview of Microsoft Access and its relational capabilities. Then we work through a five-part exercise. This stepped approach allows users to start anew in a new folder with a clean version of the project just in case they get lost or behind from the previous steps. Hopefully participants will be motivated to continue learning to use Access for statistical analysis.

Introduction

There are some library statistical projects for which Microsoft Excel is not powerful enough. Microsoft Access can be used to perform these more powerful functions. The problem is that Access can be quite challenging to learn; it’s not intuitive to just start using Access. The Charleston Conference preconference and proceedings provide a basic introduction to what Microsoft Access is and how it can be used for some basic statistics functions. After giving some background information about Access, we provide an exercise with five separate steps in which we use various Access skills. It is hoped that these exercises will give people enough of an initiation to delve into the many other aspects of Access queries, forms, and reports.

Because the data sets for the practice exercises are quite large (56 MB), flash drives were distributed during the preconference session. However, readers of these proceedings may request access to the data by email correspondence with the author (christopher.brown@du.edu).

Excel or Access—Which to Use When?

Microsoft Excel is an extremely powerful tool when used in analyzing library collection statistics, but there are some functions that require more power. Microsoft Access can be used for larger data sets, when more complex querying is required, and when one-to-many or many-to-many relationships need to be expressed.

<table>
<thead>
<tr>
<th>Excel</th>
<th>Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>One-to-one relationships</td>
<td>Possible one-to-many relationships</td>
</tr>
<tr>
<td>1,048,576 rows by 16,384 columns (Office 2010)</td>
<td>2GB database size limit</td>
</tr>
<tr>
<td>Best for small amounts of data</td>
<td>Better for larger amounts of data</td>
</tr>
<tr>
<td>Simple displays and sorts</td>
<td>Complex queries</td>
</tr>
<tr>
<td>Best for mostly numeric data</td>
<td>Best when textual data included</td>
</tr>
<tr>
<td>Best for calculations and basic statistical comparisons</td>
<td>Useful for more complex comparisons</td>
</tr>
<tr>
<td>Flat structure keeps all data together—easier to migrate</td>
<td>Relational means data lives in many tables—hard to migrate</td>
</tr>
<tr>
<td>Pivot Tables</td>
<td>Cross-tabulation queries</td>
</tr>
</tbody>
</table>

Table 1. Excel and Access compared.
Understanding Access Object Types

People find Access intimidating from the outset for many reasons. First of all, you can’t even begin to use Access without naming your database and saving it to a specific location. This model differs from that of Microsoft Word, Excel, and PowerPoint, where you simply open the application and begin doing things. With Access beginners have no idea where to start. With that in mind it is helpful to define the object types within Access and how they relate to each other.

Access Structure

The basic underlying object type is the table. All data ultimately are stored in tables and other objects like queries, forms, and reports are built off of the data stored in tables. Queries are useful for transforming data: transformations such as sorting and calculating numbers. Queries can also be used to make other tables, append records to tables, and update data in tables. We will be using each of these query types in this workshop.

Forms and reports can be built off either tables or queries, but I very highly recommend that you only build them off of queries. Building forms and reports off of queries gives you much greater flexibility as your database project evolves. Forms can be used to enter data (in the case of ongoing projects) and display data (as in charts). Reports can be used to summarize data, group data and even output into book format.

Flat World Versus Relational World

Excel represents data in a “flat” manner, but Access is capable of representing data in a relational manner. The best way for me to communicate the differences is for us to imagine together that we are building a personal address book. We need certain data fields to hold our data. We will certainly need a LastName field, a FirstName field, and perhaps a MiddleName (or initial) field (at least when thinking of the structure of names in our culture). This means that every record in our database will have a MiddleName field whether or not every person has a middle name. We also would need
appropriate address fields (Addr1, Addr2, City, State, Zip, and perhaps country).

But now we need to include information for contact information such as phone numbers. We might construct a field for HomePhone, WorkPhone, and perhaps Fax. But many people have more phone numbers than this. They may have multiple cell phone numbers, for example. We could include email address, but again, many people have a work email address, and very more than two personal email addresses. In the flat database world things are already getting overly complicated. We can continue to add multiple fields to accommodate all of these phone numbers and email address, all the while increasing the size of our database for fields that will only be used in some of the cases.

The flat database world requires us to keep adding additional fields to our personal address database, whether we need them all of not, just to accommodate the numerous varieties of contacts we encounter today. But now let’s do the same project in a relational database environment. We could construct a related table, a contacts table that could accommodate any number of contacts, from zero to an endless number. We only add a field if it is called for given the shape of the data.

This simple example shows the power of a relational database such as Microsoft Access.

When working with data projects it is essential to think of the shape of the data. What kinds of relationships exist among the various fields? Consider field types: do you need number fields, text fields? Do you need binary Y/N fields, or would this information be better represented in a text field? Librarians have special considerations to consider like standard numbers (ISBN, ISSN)—fields that even though they appear to be numbers, actually require text fields because of leading zeros, check digits, and hyphens.

In library data projects you often don’t have the luxury of planning a data project from the ground up. Often you are given data sets from vendors, your ILS, or colleagues. You may need to compare data sets from dissimilar sources; for example, print circulation statistics from your ILS and counter statistics for ebooks from a vendor. Access is particularly strong at manipulating, transforming data from these different sources.
Example of a Relational Database

To give an example of what Access can do in terms of complex relationships I present a database project I did several years ago for United Nations Centre for Regional Development publications. The UNCRD is a United Nations field office headquartered in Nagoya, Japan. The database serves as an index to their books, book chapters, journal articles, conference proceedings, and other publications. I built the database from the ground up by systematically working through publications located in their Nagoya library. I needed Access because of the complexity of relationships. One item (article, paper, chapter) could have one or many authors, and any individual author could, in turn, have one or many published items.

Figure 3. UNCRD database entry form.

The form in Figure 3 shows the main form with title and descriptive information in the upper section, with related subforms for author, relationship, and subject terms in the lower section.

Figure 4. UNCRD database relational structure.
Figure 4 shows the relationships that exist in the UNCRD database. The Title Table is the central idea. Since it is only possible to have one-to-many relationships between any two tables, an additional table is inserted between the Title Table and the Author Table. Here is a one-to-many relationship between Title and the Author Link Table, and a one-to-many relationship between the Author Table and the Author Link Table. Thus we now have a many-to-many relationship between the Title Table and the Author Table, thanks to the intervening table. The same kind of relationship exists between the Title Table and the Thesaurus Table.

Most library statistical project won’t need this kind of complexity within Access. I only provide this illustration to show the potential of a relational database in a library context.

Exercises

The best way to learn Access is to jump right in. With this in mind, I have prepared a series of datasets (JR1 reports) from eight academic libraries. All of the data has been anonymized.

This project involves comparing journal use from a particular big deal vendor across these eight academic libraries. The problem is that no two libraries have exactly the same list of journal titles. We need to figure out a way to compare data from dissimilar lists. We will do this by placing all ISBNs from each of the eight libraries into a new table, and then de-duplicating the ISBNs, thus creating a master list of ISSN. Then we will build up the table with the usage data from each of the eight libraries. Finally we will examine cost-per-use for each library by importing yet another file. This series of exercises will require the use of select queries, make table queries, append queries, and update queries. Time will not permit us to get into forms or reports.

Step 1: Clean up Excel files by removing intro rows and totals row. Import files into Access.

Go to the folder labeled Step 1 and for each of the Excel files, remove the extra rows as shown in green in Figure 5. This is necessary before importing into Access.

![Figure 5. Preparing the file for importing.](image)

Now we are ready to import each of these files into Access as separate tables. Click the External Data tab in Access and select the Excel button.

Then navigate to each of the Excel files in the Step 1 folder and import them into Access as illustrated in Figure 6.
Figure 6. Importing a file from Excel.

Just in case you didn’t understand how to do this, the Access database in Step 2 has all the data files already imported for you.

**Step 2: Create a master ISSN Table containing all ISSNs from each of the eight files.**

Be sure to navigate to the Step 2 folder within the data folder. This step involves using a query to do a make table query operation, followed by append operations. There are eight files that you need to place into a new table. The first operation will be to take the first file and use a make table query. Create a new query and drag the Print ISSN and Journal fields into the grid as illustrated in Figure 7. Then, change the query type from a select query to a make table query. You will be asked to name your new table, so create a name of your choosing. Note that this operation has already been done for you for illustrative purposes. When you are ready to create your table, click the Run button within the query. You will then see your new table when you view your existing tables.
Figure 7. Creating Master ISSN Table to hold all ISSNs.

Now that the first file has been imported with a make table query, add the others with an append query as illustrated in Figure 8. These subsequent steps are similar to the make table operation, except that we want to add (append) the same fields from the other tables to your new Master ISSN Table.

Figure 8. Appending ISSNs to Master ISSN Table.
Step 3: Deduplicate the Master ISSN Table.

Go now to the Step 3 folder. For this operation you need to create a query based on the Master ISSN Table.

When you create a new query, the default query type is the select query. In design mode of your newly created query, open the Property Sheet and select Unique Values = Yes, as illustrated in Figure 9. To see the results of this, click the View button to see your select query. You will see that what you have is just the unique ISSNs without all the duplicates.

Figure 9. Make a new query, based on the Master ISSN Table, with only unique values showing.

Now use this query to make a table called Unique ISSN Table. After clean-up you should have something like 2,603 rows.

Figure 10. Make a new table containing only unique ISSNs.
**Step 4: Update Query.** You will first need to create fields for each of your “Libs” in your newly created Unique ISSN Table.

Open the newly created Unique ISSN Table in design view, and add fields for each of your eight libraries as shown in Figure 11. Make the data type Number Double to match the format in each of the Lib tables. This step creates the empty fields into which we will place the matching data from the individual library data tables that you imported in Step 1.

![Figure 11. Add field to Unique ISSN Table to hold data from Lib tables.](image)

Now we need to get the data from the individual “Lib” tables into the corresponding fields in the Unique ISSN table. To do this we need a new query that contains both the Unique ISSN Table (the target) and each, in turn, of the “Lib” tables (the source). Then, create a query linking on the ISSN as shown. You will then make this into an update query to update the respective “Lib” fields in the Unique ISSN table. You then need to make the link between the Print ISSN field in the Unique ISSN Table and the “Lib” table by dragging a line from one to the other, the result of which is shown in Figure 12. Also, make sure your grid is as shown in Figure 12. This is the field that will be updated when we change the query from a select query to an update query. After you have changed the query to an update query and everything is set up as in Figure 12, you are ready to “run” the query (by hitting the run button).

You will do this same operation for each of the remaining Lib tables. Keep in mind that you can go to the next step to see these operations already completed for you.
We now have solved our initial problem. All libraries have use data matched up against a unique list of ISSN, with a uniform basis of comparison among all eight libraries.

**Step 5. Import cost data.**

But now we want to take things a step further. We want to see the cost-per-use for each journal. To do this we have supplied you with a data set. You will see a Cost Data Excel file in the Step 5 folder. Import this Excel file into your Access database. Next, create a linkage between your cost table and any of the tables in your database. You can use an individual library, or you can use the newly created Unique ISSN Table with all the work you have just completed.

To derive cost-per-use, create calculations in your query. First, calculate Cost-per-Use:

\[
\text{CostPerUse: } [\text{Cost}]/[\text{YTD Total}].
\]

Next, use this calculation to create a properly formatted series of cells:

\[
\text{PerUse: Format([CostPerUse],"Currency")}.\]
Link cost-per-use data with existing usage data.

Your final result will look like Figure 14.

Cost-per-use calculated in Access.

Review

We have performed many of the essential Access skills: importing data, work with make table queries, append queries, update queries, and select queries. We created linking to related fields. Being accomplished with Access involves years of building on previously learned skills and moving on the new ones. These exercises have only touched upon a few of the basic Access skill sets. There are many expensive Access guidebooks in your local bookstores, but I recommend the following one because it focuses on the skill sets needed by librarians.

Part 3. Advanced Excel Functions for Collection Analysis

Gabrielle Wiersma

Microsoft Excel 2013 offers useful features and formulas that facilitate data manipulation and collection analysis. Using journal cancellations as a workplace scenario, this paper will provide an overview of how to organize data and complete basic calculations with Excel. The paper includes instructions for importing and exporting data, combing and comparing data from different sources, and formatting data to communicate results more effectively. It also describes how to use several advanced Excel functions including Flash Fill, VLOOKUP, and other formulas.

Introduction

Librarians have access to a multitude of data about collections and usage. However, it can be difficult to connect and combine data from various sources because they are often saved in different files and formats. Using a hypothetical journal cancellation scenario, this paper highlights some of the features, functions, and formulas in Excel 2013 that make it a powerful tool for data manipulation and collection analysis. The tools and techniques described in the paper could be applied to other collection analysis projects such as evaluating renewals, marc record reconciliation, or comparing print and online usage.

This session was originally offered as a preconference workshop during the 2013 Charleston Library Conference. The session was well attended and the presenters were asked to repeat the workshop at the 2014 Conference. The 2014 preconference workshop and these proceedings build upon the 2013 presentation and paper and incorporates feedback that was received during and after the 2013 session. In addition, this paper includes additional information about new features in Excel 2013 with updated screen shots. For more information, please see the 2013 Charleston Library Conference proceedings by Denise Pan and Gabrielle Wiersma, “Excelling with Excel: Advanced Excel Functions for Collection Analysis” available online: http://dx.doi.org/10.5703/1288284315327

The following instructions will teach users how to create an Excel spreadsheet with information from various data sources, calculate cost-per-use, and analyze a set of journals based on usage. Readers could apply the same techniques to include other data such as impact factor or faculty input.

Project Goals

The most important first step in collection analysis is defining project goals and objectives. The goal of the workshop was to use Excel to identify journal titles for cancel within one hypothetical journal package. The objective was to cancel approximately $7,000 or 8% of the package based on cost per use data and usage trends.
Gathering and Importing Data

The next step is considering what types of data to collect. For a serials review project, data sources may include payment info from the Integrated Library System (ILS) and Journal Citation reports for impact factor in text format (.txt), and usage data or price lists from publishers that can be downloaded in Excel format (.xls). If the data is only available as a text file, it will need to be imported into Excel using the Text Import Wizard.

Importing Data

Excel can import data from Access, websites, text, and other sources like XML or SQL.

Click on the Data tab → Get External Data → From Text and select the text (.txt) file to open.

Text Import Wizard

Step 1 of 3

1. Is your data Fixed Width or Delimited?
2. Was the data created in a specific character set? CU Boulder’s ILS data is encoded in Unicode, UTF-8; other data sources like Serials Solutions provide the option of downloading in UTF-8 or Latin 1 encoding. Selecting the appropriate file origin will ensure that special characters and diacritics display properly in your spreadsheet.
3. Select My data has headers if the information in the first row contains columns headings.

Step 2 of 3—Delimited

For Delimited data you need to tell Excel which character delimits your data.

Use the Data Preview window to see how each character will affect your data (you can select space or enter a letter in the Other box to see how different delimiters separate the data).

Step 2 of 3—Fixed Width

Fixed width data contains data in fields of comparable or equal size. Use the preview window to add, move, or delete a column break.
Step 3 of 3

Format the data in each column: **General** converts numeric values to numbers, date values to dates, and all remaining values to text; Select **Text** for Print and Online ISSN, **General** for other columns and **Finish**.

Tell Excel where you want to paste the data. Default is Existing worksheet =$A$1.

**Text to Columns**

After data has been exported, it can be further separated using **Text to Columns**. Text to Columns can only separate one column of data at a time.

1. Insert column or columns to the right of the column that you want to separate.
2. Highlight the column of data that you want to separate.
3. Click on the Data tab **Data → Text to Columns**.

**Create a copy of your data**

Creating a copy of your data allows you to preserve a copy of your original data in one sheet and creates another copy of your data that you can clean up and manipulate. You can refer back to the original data or create additional copies as needed.

**TIP:** Create copies of your original data (you can only undo (CTRL+Z) so much!) Right-click the Sheet tab to copy, rename, or change tab color.
To create a copy of an Excel sheet:

1. Double Click or Right-click on Sheet1 → Rename ILS Data (or original data).
2. Right-click on Sheet1 → Move or Copy.
3. Select the Create a copy option.
4. Rename the copy Data Analysis.
5. OR use the Format Menu Home → Format → Organize Sheets: Rename Sheet, Move or Copy Sheet, Tab Color.

Tables

By converting data into a table, Excel creates a relationship between the data and automatically adds several features that will make it easier to format and analyze the worksheet.

For example, the first row of the Table is automatically frozen so that it will continue to display as you scroll down the spreadsheet. In addition, the Table Tools Design tab includes options to make the Header Row and/or Last Column bold, and a variety of Table Styles to change the color and shading of the Table. This menu also includes Table Style Options like Banded Rows or Columns and functions like adding Filter Buttons to the first row and a Total Row on the last row. Total Rows are useful for inserting many simple formulas such as subtotals (sum), average, counts, min, and max in any column.

To insert a Table:

1. Click on the Insert tab → Table (Ctrl + T).
2. Table Design and Style.
   a. Click on the Design tab/Table Tools \(\rightarrow\) Header Rows, Banded Rows, Filter buttons, Total Rows and Table Styles (colors and shading).
   b. Freezing the first row allows you to see the first row as you scroll down: View \(\rightarrow\) Freeze Panes (1st row is automatically frozen in a Table; you can also freeze the first column or a select number of panes).

**Sorting, AutoFill, and Flash Fill**

Sorting data is a basic but useful feature in Excel. Numeric data can be sorted smallest to largest or vice versa and text can be sorted alphabetically in ascending or descending order. If your data is was originally sorted alphabetically or by a simple numeric system you may be able to return to your original sort order. However, if you are working with data that was sorted by an alphanumeric schema like LC call number or another complex way Excel may not be able to sort the data in the correct order. Creating a numbered column with the original sort orders ensures that you can revert to the original sort order if needed.

**Create a numbered column with original sort order**

1. Right click on cell A1 and insert a table column to the left of column A.
2. Start numbering the series 1,2,3 and then use the fill handle \(\textcolor{red}{
\begin{array}{c}
    +
\end{array}
}\) to AutoFill the series down the column (drag down or double click on the square in the bottom right of the fill handle until it turns into a +).

3. Sort data by text (A to Z or Z to A), numbers (smallest to largest or largest to smallest), dates and times (oldest to newest and newest to oldest).

4. Sort by Subject, Librarian, Subscription Cost; font or fill color.

**Flash Fill**

Flash Fill is a new feature in Excel 2013 that looks for patterns in adjacent cells to format your data. It can be used to clean up data or format it in different ways. For example, it can be used for:

- changing text casing from ALL CAPS to Upper and lowercase.
- formatting numbers (ISSN ####-#### instead of #######).
- combining text (First Name Last Name \(\rightarrow\) Last Name, First Name).
To use Flash Fill:

1. **Right Click** and **Insert** a column to the right of the column that you want to format.
2. Start typing the data in the format you want to display (e.g. lowercase instead of caps or a specific number format).
3. Press **Enter** when Excel recognizes the pattern to fill down OR use **Ctrl + E**.
4. See also: **Home** → **Fill Down/Series/Flash Fill**.

**Filtering**

Filtering is another basic but extremely useful function. Filtering creates a subset of data by displaying only data that meets your criteria and hiding all of the other data.

1. Numeric fields: try filtering to find the Top 10 or 20, Above Average, Below Average journals based on subscription costs.
   a. **Filter** → **Number Filters** → **Top 10, Averages**.

   ![Figure 11. Number filters.](image)

   [Image of a spreadsheet showing a filter applied to a table of journals with subscription costs.]

   b. Text fields: look for fields that contain, equal, start with, or end with certain terms.
To clear filters, use the Clear Filter option from the dropdown or go to Home ➔ Sort and Filter ➔ Clear to clear all filters in the Table.

Highlighting and Removing Duplicates

Data sources may have duplicate values that need to be identified and removed. In the ILS data the journal title, order record numbers, and ISSNs should be unique values while the subject area, librarian, fund, and even cost may be repeated. There are two different ways to find and remove duplicate values. Use Conditional Formatting to highlight duplicate values within a column and manually delete duplicates. Use the Remove Duplicates function in Table Tools to automatically detect and delete duplicates.

1. Find duplicate values using **Conditional Formatting**.
   a. Select columns that may have duplicate values (e.g. Journal Title and Order Record).
   b. **Home ➔ Conditional formatting ➔ Highlight Cell Rules ➔ Duplicate Values**.
   c. **Sort or Filter by color** to see the duplicates.
   d. **Right Click on Row and Delete** OR use **CTRL-**
Combining Data From Multiple Spreadsheets

Librarians often need to connect data from different sources during journal cancellation projects. For example, a title list with pricing information from a publisher or ILS data with COUNTER usage stats. VLOOKUP is a formula that you can use to look up values in one spreadsheet and pull them into another sheet. It searches for a value in a table and returns a corresponding value from another column in the same row. VLOOKUP works best if there is a unique identifier to connect the data. Fortunately, most ILS data, title lists from publishers, and COUNTER usage reports include ISSNs which can be used as a match point to identify the same journal in different spreadsheets. Using the ISSN as the unique lookup value, VLOOKUP can find and enter the YTD usage statistics from a COUNTER JR1 report into a spreadsheet with your ILS data. In Excel, click on the Formulas tab → Lookup & Reference → VLOOKUP.
Figure 15. VLOOKUP formula.

Function Arguments:

3. **Lookup_value** is the unique identifier or key that is in both spreadsheets (click on the Print ISSN value in the first row).

4. **Table_Array** tell Excel where to look for the data (select the data starting with the Print ISSN of the first journal in the JR report and highlight all of the data across to YTD total and down to the end of rows).

5. **Col_Index_Number** which column to you want to pull data from and display in your spreadsheet (In COUNTER 4 reports, total is 3 columns away from Print ISSN; in older reports it is 15).

6. **Range lookup**.
   a. **TRUE** approximate match (can be used to match text fields like title but is not always accurate).
   b. **FALSE** exact match (this is useful if you only want an exact match and works well if you are using a numerical match point like ISSN).

Figure 16. VLOOKUP function arguments.

**TIPS**: use Ctrl + Shift + Arrows to select multiple cells of data. Follow the same steps to lookup impact factors or other data.
Analyzing the Data

Cost per use is one metric that can be useful for evaluating journal packages. Excel can calculate cost per use by dividing the subscription costs by the YTD usage stats. However, if a journal had 0 use Excel will display an error message, #DIV/0! because it cannot divide the subscription costs by 0. This error message can be interpreted as a title with 0 use, but it is also possible to use another Excel formula called IFERROR to calculate cost per use and change the display of the error message. For example, IFERROR can display another value like n/a, -, or the actual subscription cost instead of displaying #DIV/0!.

Calculate cost per use:

1. Create a new column for **2013 Cost Per Use**.
2. Type the formula =subscription cost/use into the formula bar.
3. If you use the simple formula to divide subscription costs by use (=subscription cost/use) then you will get the #DIV/0! error for titles with 0 use.
4. Use the **IFERROR formula** to calculate cost per use and insert subscription costs for 0 use titles.
5. **Formulas → Logical → IFERROR.**

**Figure 17. Formula bar.**

**Figure 18. IFERROR Formula.**

**Function Agreements:**

**Value:** Subscription Cost/2013 Usage.

**Value_if_error:** Subscription Cost OR type in another value (e.g. 0, n/a, zero).

**Figure 19. IFERROR Function Arguments.**
Presenting the Data

In addition to highlighting duplicate values, conditional formatting can also be used to highlight other data aspects and create graphic representations of the data. For example, Excel can create data bars that represent how much each journal title costs compared to the total subscription costs. Conditional formatting also contains various icons that can be used to visually represent data intervals. For example, red, yellow, and green icons can be added to cost-per-use to indicate high (>30), medium ($11-29), and low values (<$10) compared to average Interlibrary Loan or pay-per-view article costs. It can also highlight the top/bottom which is useful for identifying the most expensive journals and the journals with the highest cost-per-use, which would be likely candidates for cancellation. Adding graphics and icons to data helps quickly identify patterns and interpret the data without having to create separate graphs or charts.

Conditional Formatting

6. Add Data Bars for subscription costs.
   a. Highlight the data in the Subscription Cost column → Conditional Formatting → Data Bars.

7. Add Icon Sets for cost per use.
   a. Highlight the data in the Cost Per Use column → Conditional Formatting → Icon Sets → More Rules.
   b. Reverse Icon Order.
      i. Red when value is >= 30.
      ii. Green when value is >= 10.
   c. Highlight Top 8% to identify titles for cancellation.
   d. Sort by Color to see the highlighted titles at the top of the column.

**TIP:** Use metrics like average ILL costs to analyze the data
Visually Filter Data With Slicers

Slicers are tools that can be used to quickly filter data. Slicers are an optional feature of PivotTables in Excel 2010 and are now available for regular Tables in Excel 2013. Slicers work like regular filters; they create subsets of the data based on the criteria selected. Multiple slicers can be inserted so that you can filter data in different columns. In addition, the size, color, and placement can be customized in the Slicer Tools options. Slicers are another option to add visual interest to your spreadsheet and create an easy way for users to interact with the data.

8. Design/Table Tools → Insert Slicer.
9. OR Insert → Slicer.
10. Add Slicers for Subject, Librarian, Fund.
11. Use Ctrl + click to select more than one filter.

Conclusion

The final spreadsheet can be sorted, filtered, and sliced to determine which journals should be cancelled. Sorting by subscription cost and highlighting journals with high cost per use will identify some of the best candidates for cancellation. Slicers give subject librarians a quick way to review the journals in each area and conditional formatting provides visually clues to help analyze and interpret the results.

This paper demonstrated how Excel can be used to collect, format, and analyze data from various sources. The Excel tools, formulas, features, and functions used in this paper could be used for many different collection analysis projects.
Figure 24. Final spreadsheet with conditional formatting for subscription cost and cost per use and slicers for subject, librarian, and fund, and the journals with the top 8% cost per use highlighted in red.